25th August 2018

Amsterdam AMS - Network performance issue

We currently see increased latency on some of our AMS connections. We are investigating this issue.


Update: We are awaiting response from the datacenter

Update: Datacenter is working on the issue

Update: Issue resolved, we are monitoring and talking with the datacenter for more information and prevention in the future..

Update: The datacenter just send out an official response regarding the downtime. A large amplification attack on another customer caused slowness and downtime of the whole network. The datacenter has told us that additional filtering will be implemented within 7 days to prevent this in the future.