3rd September 2018

Finch Issue node Finch

We are experiencing an outage with node Finch, currently investigating.


Update 01:08: The node has been restarted.

Update 01:12: VPS servers on this node are becoming active again.

Update 01:16: All VPS servers are stable again, we will continue investigating the origin of the downtime. Status message closed for now.