19th October 2018

Client Panel Customer panel maintenance

We will upgrade our customer panel to a new version today. A small outage is expected during this upgrade. Customer services are not impacted and the WebCP is still functioning.


Update: Phase 1 of the upgrade is complete, phase 2 starting now.

Update: Phase 2 complete, working on the final phase now.

Update: All done, customer panel back online!