27th June 2018

Amsterdam AMS - Network performance issue

We are experiencing higher latency than normal on our connections in the Amsterdam datacenter. We are currently investigating this issue with the datacenter.


Update 11:23: Datacenter has been contacted, there is a DDoS attack at this moment. They are working on resolving it.

Update 11:36: The issue has been resolved.